Pobleem foto's plaatsen met FB-link

Discussie in 'Forumopmerkingen' gestart door David VB, 19 dec 2014.

  1. David VB

    David VB Sub-Adult

    Lid geworden:
    28 nov 2011
    Berichten:
    813
    Leuk Bevonden:
    53
    Trofeepunten:
    230
    Zoals al eens aangehaald kon ik vroeger (en nog op andere fora) gewoon rechtsklikken op een foto van FB en daar dan 'afbeeldingslocatie kopiëren' kiezen en die link hier tussen de img-tags zetten om een foto te plaatsen. De laatste tijd lukt dit niet meer en krijg ik volgende :

    [​IMG]


    Dit is hoe ik het zie als ik de post aan het maken ben :
     

    Bijgevoegde bestanden:

  2. persistentaura

    persistentaura Sub-Adult

    Lid geworden:
    24 apr 2012
    Berichten:
    551
    Leuk Bevonden:
    2
    Trofeepunten:
    230
    Bij mij lijkt het te werken als ik het probeer. Misschien je privacy instellingen?
     
  3. David VB

    David VB Sub-Adult

    Lid geworden:
    28 nov 2011
    Berichten:
    813
    Leuk Bevonden:
    53
    Trofeepunten:
    230
    Staan voor bijna alle albums op 'iedereen'
     
  4. Bruce1984

    Bruce1984 Adult Administrator

    Lid geworden:
    23 dec 2013
    Berichten:
    212
    Leuk Bevonden:
    33
    Trofeepunten:
    160
    Om zo'n afbeelding correct weer te laten geven, moet de URL eindigen in één van de volgende extensies: .jpg, .jpeg, .png of .gif, als dit niet het geval is zal de 'parser' (deel wat er voor zorgt dat de link wordt geconverteerd naar een afbeelding) het niet herkennen als plaatje.

    Wat ik zo kan zien is dat er een spatie tussen de 'j' en 'pg' staat, waardoor er niet '.jpg' staat, maar '.j pg'. Dat is in ieder geval één reden waarom het mogelijk niet werkt. Een andere reden is dat bepaalde media, zoals bijvoorbeeld Facebook, diverse methodes gebruiken om hun afbeeldingen op te slaan, vervolgens op te roepen en weer te geven. Dus telkens als je naar de bron kijkt en de afbeeldingslocatie kopieert, maar deze niet eindigt in één van bovenstaande extensies, zal het niet werken.

    Als ik de afbeeldingslocatie kopieer van de link die je tussen 'img' tags hebt geplaatst en deze handmatig in de browser plak, werkt deze. Logischerwijs. Maar als je vervolgens naar de adresbalk kijkt en de locatie bekijkt, zie je dat deze niet eindigt in één van de extensies (vanwege de manier waarop Facebook werkt). Zodra je het stuk na '.jpg' weghaalt en probeert de link te laten eindigen in een voorgenoemde extensie, werkt de link niet meer (vanwege de manier waarop Facebook werkt), dus zal deze ook niet te gebruiken zijn op dit forum.

    Dus zolang er geen werkende, op de juiste extensie (.jpg, .jpeg, .png of .gif) eindigende link is, zal deze niet tussen tags kunnen worden geplaatst.

    Hier zijn twee oplossingen voor mogelijk; de afbeelding op je computer opslaan en als attachment toevoegen aan een post of een externe imagehost gebruiken, daar de afbeelding uploaden en vervolgens die link op dit forum gebruiken.

    Hopelijk is dit voldoende verklaring waarom het gebruiken van de links verkregen via FB dus niet werkt hier :smile:
     
  5. persistentaura

    persistentaura Sub-Adult

    Lid geworden:
    24 apr 2012
    Berichten:
    551
    Leuk Bevonden:
    2
    Trofeepunten:
    230
    Ik denk dat hij dat gedaan heeft om de img tag te omzeilen.


    Het lijkt mij dat hij de volledig url van de afbeelding niet mee krijgt als hij op "afbeeldingslocatie kopiëren" duwt.
    Die zou https://fbcdn-sphotos-f-a.akamaihd...._=1429607552_e8032d9c6c07313b5f332682675d55d1 moeten zijn.

    tussen img tags geeft dat dit:
    [​IMG]

    Dit werkt bij mij dus duidelijk wel. Moet toch ergens aan jou liggen dan (één of andere browser/computer instelling ofzo?)
    Je kan ook altijd rechtmuisklikken en klikken op "afbeeldingsinfo bekijken". Daar staat ook de vollledige url die je dan kan kopiëren.
     
  6. Bruce1984

    Bruce1984 Adult Administrator

    Lid geworden:
    23 dec 2013
    Berichten:
    212
    Leuk Bevonden:
    33
    Trofeepunten:
    160
    Ah inderdaad, dan zal er wellicht een 'uitzondering' zijn toegevoegd in de parser van vBulletin om de Facebook links toch werkend te houden, normaal gesproken zou het niet 'moeten' werken? Maar dan zou er inderdaad iets anders aan de hand moeten zijn, als de links voor jou bijvoorbeeld wel werken. Ikzelf heb geen idee... Even testen of het voor mij werkt;

    [​IMG]

    Ah, voor mij werkt het inderdaad ook! Ik heb simpelweg de afbeeldingslocatie gekopieerd en deze tussen tags geplaatst :smile: .

    Oh... Wacht... Ik zie het probleem al - blijkbaar is bij het plaatsen alleen het stukje van de foto zelf gekopieerd, in plaats van de -gehele- URL. Als je alleen de naam van de foto + extensie plaatst, zal het niet werken, gezien het systeem de foto dan niet kan 'ophalen' (zonder site/domein waar de foto gehost is). Althans, dat is wat ik opmaak uit de drie afbeeldingen die je hebt toegevoegd; ik zie niet een hele URL staan. Er gaat dus iets fout bij of het kopiëren of het plakken van de URL gok ik.
     
  7. NDB

    NDB Adult Administrator

    Lid geworden:
    6 mrt 2012
    Berichten:
    2.630
    Leuk Bevonden:
    74
    Trofeepunten:
    240
    Ik heb het vorige week ook nagelopen: ik kan inderdaad gewoon nog foto's van Facebook hier plaatsen tussen img-tags. Zelfs vanuit een album dat op private staat (wat ik een vervelend idee vind, maar dat is even een Facebook-issue). Maarrr, dan heb ik wel de volledige url. Misschien dat de browser die Beemer gebruikt, na een update niet meer bij 'albeeldingslocatie kopieren' de hele url kopieert? Want daar zit het probleem in zo te zien.
     
  8. David VB

    David VB Sub-Adult

    Lid geworden:
    28 nov 2011
    Berichten:
    813
    Leuk Bevonden:
    53
    Trofeepunten:
    230
    Zit op een imac en kan wel zijn dat de browser een update heeft gehad. Rare is dat het op andere fora gewoon nog wel werkt.

    Test :

    [​IMG]
     
  9. David VB

    David VB Sub-Adult

    Lid geworden:
    28 nov 2011
    Berichten:
    813
    Leuk Bevonden:
    53
    Trofeepunten:
    230
    Had nu op FB onder de foto op opties gedrukt en daar 'link ophalen' gekozen. Toen zag ik de volledige link en die heb ik hier gekopieerd en tussen de tags gezet.
     
  10. David VB

    David VB Sub-Adult

    Lid geworden:
    28 nov 2011
    Berichten:
    813
    Leuk Bevonden:
    53
    Trofeepunten:
    230
    Test 2 :

    [​IMG]
     
  11. David VB

    David VB Sub-Adult

    Lid geworden:
    28 nov 2011
    Berichten:
    813
    Leuk Bevonden:
    53
    Trofeepunten:
    230
    Nu heb ik de foto geopend in een nieuw venster en dan de link zo gekopieerd. Werkte eerst niet, maar toen ik het bericht wou editten, kwam de foto er plots wel op...
     
  12. NDB

    NDB Adult Administrator

    Lid geworden:
    6 mrt 2012
    Berichten:
    2.630
    Leuk Bevonden:
    74
    Trofeepunten:
    240
    Typisch... is dit nu een goede oplossing?
     
  13. David VB

    David VB Sub-Adult

    Lid geworden:
    28 nov 2011
    Berichten:
    813
    Leuk Bevonden:
    53
    Trofeepunten:
    230
    Niet de beste, maar het moet maar zo... In ieder geval al dank om mee te zoeken :wink:
     

Deel Deze Pagina